Enterprise-class deployment automation, small business price

We work closely with your IT staff to provide extremely tailored, software deployment services, and because we scale across customers, we do it better, faster, and cheaper than in-house solutions.

Skip the imaging process. We’ll automate, customize, and maintain purely scripted Windows installations, including software installations, joining a domain, applying security policies, enabling BitLocker, and much more, all without requiring user intervention and resulting in a very consistent and stable environment.

Our packaging and deployment services are ideal for companies with 200 to 5000 employees.  If you would like to discuss options for your environment, please contact us today!

New: Intuit QuickBooks Enterprise Solutions 18.0 R4

Intuit QuickBooks Enterprise Solutions 18.0 R4
Bookkeeping software that combines a variety of accounting processes into one system

  • Abort the installation if QuickBooks is running
  • Install the prerequisites:
    • .NET Framework 4.6.2
    • Visual C++ 2010 Redistributable (x86), only on 32-bit editions of Windows
    • Visual C++ 2010 Redistributable (x64), only on 64-bit editions of Windows
    • Visual C++ 2012 Redistributable (x86), on 32-bit and 64-bit editions of Windows
    • Visual C++ 2012 Redistributable (x64), only on 64-bit editions of Windows
    • Visual C++ 2015 Redistributable (x86), on 32-bit and 64-bit editions of Windows
    • Visual C++ 2015 Redistributable (x64), only on 64-bit editions of Windows
  • Install QuickBooks
    • Activate the customer’s license
    • Accept the software license agreement
  • Delete the desktop shortcut
  • Install ABS PDF

Continue reading

New: Adobe Flash Player 28.0.0.161

Adobe Flash Player 28.0.0.161
Stream Flash video and audio within your web browser

Version 28.0.0.161 addresses a critical vulnerability (CVE-2018-4878) that could lead to remote code execution

This package includes a WSUS deployable CAB file, complete with deployment and reporting rules

  • Install Flash Player for NPAPI applications such as Firefox and Netscape
  • Install Flash Player for PPAPI applications such as Opera and Chromium-based browsers
  • Install Flash Player for Internet Explorer, only on Windows 7 or earlier
    • Beginning with Windows 8, Adobe Flash is included with Internet Explorer and updated through the Windows Update service
  • Disable automatic updates, only on domain joined systems

Continue reading

New: Microsoft Speculation Control Validation PowerShell Script 1.0.4

Microsoft Speculation Control Validation PowerShell Script 1.0.4
Determine firmware and OS vulnerably to Meltdown (CVE-2017-5754) and Spectre (CVE-2017-5753 & CVE-2017-5715) exploits

This package includes a WSUS deployable CAB file, complete with deployment and reporting rules.

  • Uninstall existing versions
  • Install the PowerShell module: SpeculationControl
  • Run the validation tool and log the results
    • PowerShell’s execution policy is only modified within the context of this tool
  • Set the exit code based on the assessment:
    • 320 – Not Vulnerable – The firmware and OS are patched
    • 321 – Vulnerable – The firmware and OS are unpatched
    • 322 – Vulnerable – The OS is patched but vulnerable because the firmware is unpatched
    • 323 – Vulnerable – The firmware and OS are patched but the OS is vulnerable because of an OS policy
    • 324 – Vulnerable – The firmware is patched, but the OS is unpatched
    • 325 – Unable to parse the assessment results, please check the log file
  • For simplified reporting, write the exit code to:
    • 64-bit systems: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\MassDeploy\History\Microsoft Speculation Control Validation PowerShell Script 1.0.4 | Last Exit Code
    • 32-bit systems: HKEY_LOCAL_MACHINE\SOFTWARE\MassDeploy\History\Microsoft Speculation Control Validation PowerShell Script 1.0.4 | Last Exit Code
  • Display the results, but only when run in interactive mode

Continue reading

New: Intel-SA-00086 Discovery Tool 1.0.0.152 for the November 2017 ME Vulnerability

Intel-SA-00086 Discovery Tool 1.0.0.152 for the November 2017 ME Vulnerability
Determine whether a system is vulnerable to the exploits documented in Intel Security Advisory INTEL-SA-00086

This package includes a WSUS deployable CAB file, complete with deployment and reporting rules.

  • Check hardware compatibility
    • Abort with one of the following exit codes, if the discovery tool is not applicable to the system:
      • 110 – Not applicable to virtual machines
      • 111 – Not applicable to non-Intel processors
  • Abort the installation if the Discovery Tool is running
  • Run the Discovery Tool and log the results
  • Set the exit code based on the assessment:
    • 320 – Not vulnerable
    • 321 – HECI is not installed (Are we missing Intel ME/TXE drivers?)
    • 322 – HECI error
    • 323 – Vulnerable, has not been patched
    • 324 – Not vulnerable, has been patched
    • 325 – Unable to determine vulnerability
    • 326 – Failed to get the assessment results
  • For simplified reporting, write the exit code to:
    • 64-bit systems: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\MassDeploy\History\Intel-SA-00086 Discovery Tool 1.0.0.152 for the November 2017 ME Vulnerability | Last Exit Code
    • 32-bit systems: HKEY_LOCAL_MACHINE\SOFTWARE\MassDeploy\History\Intel-SA-00086 Discovery Tool 1.0.0.152 for the November 2017 ME Vulnerability | Last Exit Code
  • Display the results, but only when run in interactive mode

Continue reading

Updated: Lenovo Driver Pack – ThinkPad T450, T550, W550, X250, X1 Carbon (3rd Gen)

Lenovo Driver Pack – ThinkPad T450, T550, W550, X250, X1 Carbon (3rd Gen)
Drivers, firmware, and software for the Lenovo ThinkPad T450, T450s, T550, W550s, X250, and X1 Carbon (20BS, 20BT)

Updated the applicability rules to detect the X1 Carbon (3rd Gen)’s new naming convention in the BIOS

  • Abort the installation if the Microsoft Driver Package Installer is running
  • Check hardware compatibility
  • Choose the driver repository based on the system model and OS version
    • ThinkPad T450 – Windows 10 64-bit – Version 03 (10/10/2016)
    • ThinkPad T450 – Windows 7 64-bit & 32-bit – Version 04 (03/10/2016)
    • ThinkPad T450s – Windows 10 64-bit – Version 03 (10/10/2016)
    • ThinkPad T450s – Windows 7 64-bit & 32-bit – Version 04 (03/10/2016)
    • ThinkPad T550 – Windows 10 64-bit – Version 01 (11/17/2016)
    • ThinkPad T550 – Windows 7 64-bit & 32-bit – Version 04 (02/29/2016)
    • ThinkPad W550s – Windows 10 64-bit – Version 01 (11/17/2016)
    • ThinkPad W550s – Windows 7 64-bit & 32-bit – Version 04 (02/29/2016)
    • ThinkPad X250 – Windows 10 64-bit – Version 01 (10/31/2016)
    • ThinkPad X250 – Windows 7 64-bit & 32-bit – Version 03 (02/23/2016)
    • ThinkPad X1 Carbon (3rd Gen) – Windows 10 64-bit – Version 01 (10/31/2016)
    • ThinkPad X1 Carbon (3rd Gen) – Windows 7 64-bit & 32-bit – Version 03 (02/23/2016)
  • Install all drivers, even if matching hardware is not found
    • Suppress all prompts to install unsigned drivers, except in interactive mode
    • Suppress the addition of entries to Programs and Features in the Control Panel
  • Suppress the BitLocker recovery prompt during the next reboot, only on BitLocker protected systems
    • The BitLocker recovery prompt is often triggered by BIOS updates
  • Suppress the automatic reboot after installing Intel Bluetooth Drivers
  • Reconfigure the BIOS installers for unattended installation
  • Install applicable system packages
  • Install Lenovo Mobile Broadband Activation, only when a WWAN card is present, and only on Windows 7
  • Schedule a re-assessment of the system’s graphics capabilities at next log on
  • Display a summary of driver installations and failures, only in interactive mode

Continue reading

New: 7-Zip 18.00 beta

7-Zip 18.00 beta
An open source utility for manipulating archives. Formats include 7z, ZIP, RAR, TAR, ISO, WIM and more.

Version 18.00 beta addresses arbitrary code execution vulnerabilities (CVE-2018-5996) and (CVE-2017-17969)

This package includes a WSUS deployable CAB file, complete with deployment and reporting rules

  • Abort the installation if 7-Zip is running
  • Choose the installer, based on the OS architecture
  • Install 7-Zip
    • Set file associations

Continue reading

New: Dell Command PowerShell Provider 2.0.0.280

Dell Command PowerShell Provider 2.0.0.280
A PowerShell module that provides BIOS configuration functions for Dell client Enterprise systems

  • Choose the installer for the prerequisite: Visual C++ Redistributable 2010 SP1, based on the OS architecture
  • Install the prerequisite: Visual C++ Redistributable 2010 SP1
  • Choose the installer for the prerequisite: Visual C++ Redistributable 2012 Update 4, based on the OS architecture
  • Install the prerequisite: Visual C++ Redistributable 2012 Update 4
  • Choose the PowerShell module based on the OS architecture
  • Uninstall existing versions
  • Install the PowerShell module: DellBIOSProvider

Continue reading

Mass deployment, as a service